CORS Errors
Incident Report for SimpleLocalize
Postmortem

Traefik (edge router) intermittently stops adding the 'Access-Control-Allow-Origin' header for several selected endpoints without any apparent reason, requiring a service restart. Unfortunately, this issue has persisted for some time and persists across version changes. The problem has been addressed by adding this header at the Cloudflare level to prevent its recurrence.

https://community.traefik.io/t/traefik-not-setting-access-control-allow-origin-header/14961

Posted Feb 20, 2024 - 10:47 CET

Resolved
There was an issue with some API endpoints as they were not returning the "Access-Control-Allow-Origin" header, which could cause problems with sending requests to the system for certain integrations.
Posted Feb 19, 2024 - 18:45 CET